1 post / 0 new
ForumImport
Offline
Last seen: 9 years 5 months ago
Joined: 09/22/2009 - 18:47
build development version

This message was originally posted by Heiko Irrgang on 03/01/2007 11:32:59
i tried to compile development version from cvs as described on the wiki pages on ubuntu linux 6.10, amd64
i have cmake 2.4 as requested (cmake version 2.4-patch 3)
i make a build directory out side the source tree and start cmake or ccmake with:
cmake ~/src/ext/k3d/k3d/
all i get is:
CMake Error: Error in cmake code at
/home/god/src/ext/k3d/k3d/cmake/modules/OutOfSourceBuild.cmake:4:
MESSAGE K-3D requires an out of source build. Please create a separate build directory and run ’cmake path_to_k3d [options]’ there.
Current CMake stack: /home/god/src/ext/k3d/k3d/CMakeLists.txt;/usr/share/CMake/Modules/CMakeCInformation.cmake;/usr/share/CMake/Modules/CMakeCXXInformation.cmake;/home/god/src/ext/k3d/k3d/cmake/modules/OutOfSourceBuild.cmake
CMake Error: You have requested backwards compatibility with CMake version 1.2 or earlier. This version of CMake only supports backwards compatibility with CMake 1.4 or later. For compatibility with 1.2 or earlier please use CMake 2.0
-- Configuring done
any ideas? thanx in advance