6 posts / 0 new
Last post
ForumImport
Offline
Last seen: 9 years 11 months ago
Joined: 09/22/2009 - 18:47
K-3D will only render with bundled Aqsis

Hey there.
First off, let me say I very much like K-3D, particularly for it's renderman integration. I'm primarily a Blender user, but for years and years have wanted to and repeatedly tried to learn how to use renderman, with little success.
Anyhow, my problem is this.
K-3D (v0.7.11.0) installed fine (win xp sp3), as did Aqsis (v1.6.0). I can render using Aqsis from the command line just fine. However, when I set Aqsis as my renderman engine in K-3D, I get nothing when I press preview or render, although it doesn't complain about not being able to find it. However, it works just fine if I set the renderman engine to BundledAqsis.
Curious, as past builds I tried worked fine with the separate install of Aqsis. Am I doing something wrong? I can find nowhere in K-3D to set any further parameters regarding this.
Thank you in advance. I'm sure I'm just missing something.

ForumImport
Offline
Last seen: 9 years 11 months ago
Joined: 09/22/2009 - 18:47
K-3D will only render with bundled Aqsis

Just to triple check my Aqsis install, I went into Blender and rendered a simple scene out using Mosaic. That also worked fine, so it must be something in K-3D ...

ForumImport
Offline
Last seen: 9 years 11 months ago
Joined: 09/22/2009 - 18:47
K-3D will only render with bundled Aqsis

The only difference between "BundledAqsis" and "Aqsis" is that the former knows exactly where the Aqsis executable is located, since it's included in the installer. The latter searches for "aqsis" using the contents of the PATH environment variable. So my first guess is that your PATH needs to be updated. Try running K-3D from the command line, and post any warnings / errors that you see when you render.
Cheers,
Tim

ForumImport
Offline
Last seen: 9 years 11 months ago
Joined: 09/22/2009 - 18:47
K-3D will only render with bundled Aqsis

I ran K-3D from the command line, and got no output from K-3D whatsoever. It started up and ran fine, but printed nothing to the console. Is there a command switch I need to use?
regardless, I know my PATH is correct and working for Aqsis, as I can render from any directory on my machine, plus use it in Blender. K-3D log window shows that it tries to start the render, and I see an hourglass for in instant, but the renderer never starts up. Is there maybe some config file for K-3D I should look into altering?

ForumImport
Offline
Last seen: 9 years 11 months ago
Joined: 09/22/2009 - 18:47
K-3D will only render with bundled Aqsis

Yeah, I always forget that the Win32 console doesn't work with GUI applications; to see stdout and stderr on Windows, you can run K-3D from within a cygwin xterm. As an alternative, you might try running K-3D from DependencyWalker, which might give us some insight.
Cheers,
Tim

ForumImport
Offline
Last seen: 9 years 11 months ago
Joined: 09/22/2009 - 18:47
K-3D will only render with bundled Aqsis

For running this on windows, Process Monitor from Sysinternals maybe of some help. http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx
You can monitor your system, filter out what you don't care about and see where and how and with which parameters K-3D is trying to calling Aqsis.
In the Process Monitor output, once you see Aqsis being called, you will see if it found the file or not. As K-3D searches through the PATH for Aqsis, there should be at least one valid File not found result for the working directory and then it should search the path for the executable. If it never finds it, you can see that in this tool.
If it is called, you can right-click on the process and see what parameters it was launched with, etc...

Log in or register to post comments